?

Log in

 
 
25 September 2008 @ 11:09 am
aw man  
IE version 8 does not like LJ. I can not see what I am typing, so let's post this biz and see what happens!
 
 
 
Progression/Regression.resistdeath on September 25th, 2008 04:14 pm (UTC)
Get hip and get Mozilla!
valeriecardiorrhexis on September 25th, 2008 05:00 pm (UTC)
Well I'm at work and I don't like downloading stuff here. I'd feel lame to download Mozilla just to update my LJ.